Xen Project Q&A Forum: First Line Help for Simple Questions

This is your chance to ask questions and provide answers about basic use of the Xen Project software. For debugging problems and for more complex issues, consider using the xen-users mailing list instead. You can find information about xen-users under "HELP | Mailing Lists" in the navigation bar above.


missing shared libraries

posted in Hypervisor
Tuesday, December 31 2013, 05:01 PM
Debian Wheezy 7.3 amd64
built and installed Xen 4.3.1 from source

there are a couple of issues when building from source i noticed that i had to clean up. for instance in the /boot dir the install process adds extra things that causes update-grub to complain about. removing the file xen-syms-4.3.1 causes no issues with using xen that i have noticed. what is its purpose?

second after issuing make install and the process completes i have to run insserv xendomains, xencommons & xen-watchdog. xend is added to /etc/init.d and i haven't set it up to boot, seems like a problem if i do.

third some libraries are not loaded into correct dirs and linking them to /usr/lib is required to run correctly.

final problem so far is when i run xl top i get the following error

xentop: error while loading shared libraries: libxenctrl.so.4.2: cannot open shared object file: No such file or directory

i cannot find it anywhere. any ideas? libxenctrl.so.4.3.0 is located in /usr/local/lib but its not complaining about that one is it? i linked to that file in /usr/lib and still the error, also tried linking to it like this

ln -s /usr/local/lib/libxenctrl.so.4.3.0 /usr/lib/libxenctrl.so.4.2

but that causes a segmentation fault so that is a no go!

Accepted Answer

Tuesday, December 31 2013, 07:17 PM - #permalink
i have no idea what happened but NOW xl top works without the error message! i made no other changes except to install these

blktap-dkms 2.0.91-1
cpp-4.6 (4.6.3-14)
gcc-4.6 (4.6.3-14)
gcc-4.6-base (4.6.3-14)
linux-headers-3.2.0-4-common-rt (3.2.53-2)
linux-headers-3.2.0-4-rt-amd64 (3.2.53-2)
linux-headers-rt-amd64 (3.2+46)
linux-kbuild-3.2 (3.2.17-1)
The reply is currently minimized Show
Responses (2)
  • Accepted Answer

    Tuesday, December 31 2013, 06:04 PM - #permalink

    Lumping four things in one question makes things a bit awkward, but let's see what we can do.

    For issue one, the update-grub problem, does this email appear to describe your issue?


    If so, Ian Campbell replies to that thread with the following suggestion:

    "update-grub cannot cope with the naming scheme for the symlinks which
    Xen installs. Debian/Ubuntu packages DTRT here but for source installs
    you should be able to nuke the problematic symlinks, as long as the real
    file still exists it should be fine."

    Also, have you reviewed this Debian page as well to see if any of the suggestions about running Xen on Debian might apply to your circumstance?


    Let us know which problems remain and we'll see what answers we can find.


    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 31 2013, 06:58 PM - #permalink
    so i tried to quote your message, but not working!

    as far as the update-grub issue goes, yes that is what i am experiencing and yes i followed those steps to solve my problem. i just wanted to make SURE that i was doing things the right way. i do not want to delete something that in the long run will cause errors. that post worked for me. thanks!

    as for the rest...sorry about putting all of this into one posting, i just want to consolidate all of my issues into one place.

    my second and third issues were fixed by me, its what i did to fix my problem. i was hoping that someone would say 'Oh thats not the right way, here is the correct thing you missed'. what i did manually fixed my issue, but shouldn't the build process do that for me? i mean three files are added to /etc/init.d but i have to manually finish the process by telling debian to start them

    insserv xendomains
    insserv xencommon
    insserv xen-watchdog

    my fourth issue is the real problem. missing libraries! how to fix those complaints? specifically when i run the command 'xl top' this error pops up

    xentop: error while loading shared libraries: libxenctrl.so.4.2: cannot open shared object file: No such file or directory

    any thoughts on that? i searched and nothing comes up that talks about this issue?
    The reply is currently minimized Show
Your Reply