Xen Project Q&A Forum: First Line Help for Simple Questions

This is your chance to ask questions and provide answers about basic use of the Xen Project software. For debugging problems and for more complex issues, consider using the xen-users mailing list instead. You can find information about xen-users under "HELP | Mailing Lists" in the navigation bar above.

Issue

xorg doesn't start (syslinux, archlinux, xen-git)

posted in Hypervisor
Saturday, September 07 2013, 07:14 AM
0
I'm pulling Xen from the git (4.4 unstable) repository and building it without any issues.
I'm dual-booting Xen+Arch via Syslinux mboot.c32 which works fine.

Actually, it all works fine except for two quirks (one of them being Xorg doesn't start properly).

After booting the "dualboot" Xen+Arch with the following syslinux.cfg:

LABEL Xen
        MENU LABEL XenArch
        KERNEL mboot.c32
        APPEND ../xen-4.4-unstable.gz dom0_mem=1024M --- ../vmlinuz-linux root=/dev/sda1 rw --- ../initramfs-linux.img


I get into a "fully" working Arch with Xen kernel.
There are some glitches, for instance the bootup shows:
[FAILED] Failed to start Load Kernel Modules.
See 'systemctl status systemd-modules-load.service' for details


The status of the systemd service isn't really sheading any light either (this is arch specific tho so ignore this part, just here for reference):
systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static)
   Active: failed (Result: exit-code) since Sat 2013-09-07 00:29:22 CEST; 55s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 163 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.


And my Xorg.log says:
[    22.658] Kernel command line: root=/dev/sda1 rw
[    22.659] Build Date: 01 July 2013  10:48:42AM
[    22.659]  
[    22.659] Current version of pixman: 0.30.2
[    22.659]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    22.659] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    22.660] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep  6 23:23:30 2013
[    22.662] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    22.664] (==) No Layout section.  Using the first Screen section.
[    22.664] (==) No screen section available. Using defaults.
[    22.664] (**) |-->Screen "Default Screen Section" (0)
[    22.664] (**) |   |-->Monitor ""
[    22.664] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    22.664] (==) Automatically adding devices
[    22.664] (==) Automatically enabling devices
[    22.664] (==) Automatically adding GPU devices
[    22.667] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    22.667]    Entry deleted from font path.
[    22.667] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    22.667]    Entry deleted from font path.
[    22.667] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    22.667]    Entry deleted from font path.
[    22.667]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    22.667] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    22.668]    Entry deleted from font path.
[    22.668]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    22.668] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/
[    22.668] (==) ModulePath set to "/usr/lib/xorg/modules"
[    22.668] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    22.668] (II) Loader magic: 0x7fdc20
[    22.668] (II) Module ABI versions:
[    22.668]    X.Org ANSI C Emulation: 0.4
[    22.668]    X.Org Video Driver: 14.1
[    22.668]    X.Org XInput driver : 19.1
[    22.668]    X.Org Server Extension : 7.0
[    22.668] (II) xfree86: Adding drm device (/dev/dri/card0)
[    22.672] (--) PCI:*(0:1:0:0) 10de:0e3a:1028:04a4 rev 161, Mem @ 0xde000000/33554432, 0xd0000000/134217728, 0xd8000000/67108864, I/O @ 0x00007000/128, BIOS @ 0x????????/524288
[    22.672] Initializing built-in extension Generic Event Extension
[    22.672] Initializing built-in extension SHAPE
[    22.673] Initializing built-in extension MIT-SHM
[    22.673] Initializing built-in extension XInputExtension
[    22.673] Initializing built-in extension XTEST
[    22.673] Initializing built-in extension BIG-REQUESTS
[    22.673] Initializing built-in extension SYNC
[    22.673] Initializing built-in extension XKEYBOARD
[    22.673] Initializing built-in extension XC-MISC
[    22.673] Initializing built-in extension SECURITY
[    22.674] Initializing built-in extension XINERAMA
[    22.674] Initializing built-in extension XFIXES
[    22.674] Initializing built-in extension RENDER
[    22.674] Initializing built-in extension RANDR
[    22.674] Initializing built-in extension COMPOSITE
[    22.674] Initializing built-in extension DAMAGE
[    22.674] Initializing built-in extension MIT-SCREEN-SAVER
[    22.674] Initializing built-in extension DOUBLE-BUFFER
[    22.675] Initializing built-in extension RECORD
[    22.675] Initializing built-in extension DPMS
[    22.675] Initializing built-in extension X-Resource
[    22.675] Initializing built-in extension XVideo
[    22.675] Initializing built-in extension XVideo-MotionCompensation
[    22.675] Initializing built-in extension XFree86-VidModeExtension
[    22.675] Initializing built-in extension XFree86-DGA
[    22.675] Initializing built-in extension XFree86-DRI
[    22.676] Initializing built-in extension DRI2
[    22.676] (II) LoadModule: "glx"
[    22.679] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    22.768] (II) Module glx: vendor="NVIDIA Corporation"
[    22.768]    compiled for 4.0.2, module version = 1.0.0
[    22.768]    Module class: X.Org Server Extension
[    22.768] (II) NVIDIA GLX Module  325.15  Wed Jul 31 18:12:00 PDT 2013
[    22.769] Loading extension GLX
[    22.769] (==) Matched nouveau as autoconfigured driver 0
[    22.769] (==) Matched nvidia as autoconfigured driver 1
[    22.769] (==) Matched nv as autoconfigured driver 2
[    22.769] (==) Matched nouveau as autoconfigured driver 3
[    22.769] (==) Matched nvidia as autoconfigured driver 4
[    22.769] (==) Matched nv as autoconfigured driver 5
[    22.769] (==) Matched vesa as autoconfigured driver 6
[    22.769] (==) Matched modesetting as autoconfigured driver 7
[    22.769] (==) Matched fbdev as autoconfigured driver 8
[    22.769] (==) Assigned the driver to the xf86ConfigLayout
[    22.769] (II) LoadModule: "nouveau"
[    22.770] (WW) Warning, couldn't open module nouveau
[    22.770] (II) UnloadModule: "nouveau"
[    22.770] (II) Unloading nouveau
[    22.770] (EE) Failed to load module "nouveau" (module does not exist, 0)
[    22.770] (II) LoadModule: "nvidia"
[    22.770] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    22.780] (II) Module nvidia: vendor="NVIDIA Corporation"
[    22.780]    compiled for 4.0.2, module version = 1.0.0
[    22.780]    Module class: X.Org Video Driver
[    22.781] (II) LoadModule: "nv"
[    22.781] (WW) Warning, couldn't open module nv
[    22.781] (II) UnloadModule: "nv"
[    22.781] (II) Unloading nv
[    22.781] (EE) Failed to load module "nv" (module does not exist, 0)
[    22.781] (II) LoadModule: "vesa"
[    22.782] (WW) Warning, couldn't open module vesa
[    22.782] (II) UnloadModule: "vesa"
[    22.782] (II) Unloading vesa
[    22.782] (EE) Failed to load module "vesa" (module does not exist, 0)
[    22.782] (II) LoadModule: "modesetting"
[    22.782] (WW) Warning, couldn't open module modesetting
[    22.782] (II) UnloadModule: "modesetting"
[    22.782] (II) Unloading modesetting
[    22.782] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    22.782] (II) LoadModule: "fbdev"
[    22.782] (WW) Warning, couldn't open module fbdev
[    22.782] (II) UnloadModule: "fbdev"
[    22.782] (II) Unloading fbdev
[    22.782] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    22.783] (II) NVIDIA dlloader X Driver  325.15  Wed Jul 31 17:50:57 PDT 2013
[    22.783] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    22.783] (++) using VT number 1
[    22.786] (II) Loading sub module "fb"
[    22.786] (II) LoadModule: "fb"
[    22.786] (II) Loading /usr/lib/xorg/modules/libfb.so
[    22.788] (II) Module fb: vendor="X.Org Foundation"
[    22.788]    compiled for 1.14.2, module version = 1.0.0
[    22.788]    ABI class: X.Org ANSI C Emulation, version 0.4
[    22.788] (WW) Unresolved symbol: fbGetGCPrivateKey
[    22.788] (II) Loading sub module "wfb"
[    22.788] (II) LoadModule: "wfb"
[    22.788] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    22.789] (II) Module wfb: vendor="X.Org Foundation"
[    22.789]    compiled for 1.14.2, module version = 1.0.0
[    22.789]    ABI class: X.Org ANSI C Emulation, version 0.4
[    22.789] (II) Loading sub module "shadow"
[    22.789] (II) LoadModule: "shadow"
[    22.789] (II) Loading /usr/lib/xorg/modules/libshadow.so
[    22.790] (II) Module shadow: vendor="X.Org Foundation"
[    22.790]    compiled for 1.14.2, module version = 1.1.0
[    22.790]    ABI class: X.Org ANSI C Emulation, version 0.4
[    22.790] (II) Loading sub module "ramdac"
[    22.790] (II) LoadModule: "ramdac"
[    22.790] (II) Module "ramdac" already built-in
[    22.793] (II) NVIDIA(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    22.793] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    22.793] (==) NVIDIA(0): RGB weight 888
[    22.793] (==) NVIDIA(0): Default visual is TrueColor
[    22.793] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    22.793] (**) NVIDIA(0): Enabling 2D acceleration
[    23.775] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
[    23.781] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    23.781] (II) NVIDIA(GPU-0):     stereo.
[    23.782] (II) NVIDIA(0): NVIDIA GPU Quadro 3000M (GF104GL) at PCI:1:0:0 (GPU-0)
[    23.782] (--) NVIDIA(0): Memory: 2097152 kBytes
[    23.782] (--) NVIDIA(0): VideoBIOS: 70.04.3a.01.01
[    23.782] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    23.788] (--) NVIDIA(0): Valid display device(s) on Quadro 3000M at PCI:1:0:0
[    23.788] (--) NVIDIA(0):     CRT-0
[    23.788] (--) NVIDIA(0):     LGD (DFP-0) (boot, connected)
[    23.788] (--) NVIDIA(0):     DFP-1
[    23.788] (--) NVIDIA(0):     DFP-2
[    23.788] (--) NVIDIA(0):     DFP-3
[    23.788] (--) NVIDIA(0):     DFP-4
[    23.788] (--) NVIDIA(0):     DFP-5
[    23.788] (--) NVIDIA(0):     DFP-6
[    23.788] (--) NVIDIA(0):     DFP-7
[    23.788] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[    23.788] (--) NVIDIA(0): LGD (DFP-0): 330.0 MHz maximum pixel clock
[    23.788] (--) NVIDIA(0): LGD (DFP-0): Internal Dual Link LVDS
[    23.788] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[    23.788] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[    23.788] (--) NVIDIA(0): DFP-2: 165.0 MHz maximum pixel clock
[    23.788] (--) NVIDIA(0): DFP-2: Internal Single Link TMDS
[    23.788] (--) NVIDIA(0): DFP-3: 165.0 MHz maximum pixel clock
[    23.788] (--) NVIDIA(0): DFP-3: Internal Single Link TMDS
[    23.788] (--) NVIDIA(0): DFP-4: 480.0 MHz maximum pixel clock
[    23.788] (--) NVIDIA(0): DFP-4: Internal DisplayPort
[    23.788] (--) NVIDIA(0): DFP-5: 480.0 MHz maximum pixel clock
[    23.788] (--) NVIDIA(0): DFP-5: Internal DisplayPort
[    23.788] (--) NVIDIA(0): DFP-6: 480.0 MHz maximum pixel clock
[    23.788] (--) NVIDIA(0): DFP-6: Internal DisplayPort
[    23.788] (--) NVIDIA(0): DFP-7: 480.0 MHz maximum pixel clock
[    23.788] (--) NVIDIA(0): DFP-7: Internal DisplayPort
[    23.788] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    23.788] (**) NVIDIA(0):     device LGD (DFP-0) (Using EDID frequencies has been
[    23.788] (**) NVIDIA(0):     enabled on all display devices.)
[    23.789] (==) NVIDIA(0): 
[    23.789] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    23.789] (==) NVIDIA(0):     will be used as the requested mode.
[    23.789] (==) NVIDIA(0): 
[    23.789] (II) NVIDIA(0): Validated MetaModes:
[    23.789] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select{}"
[    23.789] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[    24.856] (--) NVIDIA(0): DPI set to (128, 124); computed from "UseEdidDpi" X config
[    24.856] (--) NVIDIA(0):     option
[    24.856] (WW) NVIDIA(0): UBB is incompatible with the Composite extension.  Disabling
[    24.856] (WW) NVIDIA(0):     UBB.
[    24.856] (--) Depth 24 pixmap format is 32 bpp
[    24.857] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[    24.857] (II) NVIDIA:     access.
[    24.867] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    24.867] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    24.867] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    24.867] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    24.867] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    24.867] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    24.867] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    24.867] (II) NVIDIA(0):     Config Options in the README.
[    24.873] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select{}"


I'm wondering if anyone else have ever bumped into this issue?
I've found a couple of forums posts about it but they're tightly related to Gentoo:

* [url]http://forums.gentoo.org/viewtopic-t-941270-start-0.html[/url]
* [url]http://forums.gentoo.org/viewtopic-t-916090-start-0.html[/url]

And I'm not even convinced they're even remotely close to what i'm experiencing.

Location [ View Larger Map ]

Responses (0)
  • There are no replies here yet.
Your Reply