Xen Project Q&A Forum: First Line Help for Simple Questions

This is your chance to ask questions and provide answers about basic use of the Xen Project software. For debugging problems and for more complex issues, consider using the xen-users mailing list instead. You can find information about xen-users under "HELP | Mailing Lists" in the navigation bar above.

xl create failed of PV

posted in Hypervisor
Tuesday, February 11 2014, 03:16 PM
0
Hello,

I'm trying to install Xen onto a Gentoo.
Xen is booting up, xl list shows Dom0.
Now when i try to xl create i get the error message:

libxl: error: libxl_dm.c:1275:device_model_spawn_outcome: (null): spawn failed (rc=-3)
libxl: error: libxl_create.c:1075:domcreate_devmodel_started: device model did not start: -3

Also it complains about qemu-dm missing, which i think is not relevant since i only want to boot into my PV, at this stage i do not care about virtualization options.
As far is i understood, qemu is only needed for hvm guests.

I did my setup on a few different machines getting always stuck on this error.
If anyone could offer me support, i would highly appreciate it.

Also please tell me, which infos you need from me.
I configured everything following the Guide on XenWiki.


Thanks in advance
Responses (2)
  • Accepted Answer

    Tuesday, February 11 2014, 03:36 PM - #permalink
    0
    Sann,

    Which versions of Xen and Gentoo?

    Was your Xen version from a Gentoo repository, or did you install from a different source?

    Thanks,

    Russ
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 13 2014, 11:13 AM - #permalink
    0
    Hello Russ,

    im using Gentoo 2.2 Base System 3.10.25 with Xen 4.3.1-r1.
    I installed with emerge from Gentoo repository.
    The reply is currently minimized Show
Your Reply