Issue

[Help] is xen-tools changing my dom0 keymap?

posted in General
Monday, August 05 2013, 02:03 PM
0
Hi, pretty new to Xen but have a working dom0 with ubuntu 12.04.2 and a built xen-4.3.0 installation.

I've built xen-tools-4.3.1 and am using this to provision new domU's...early days yet for me but this is all working as per the various guides and a lot of googling.

One thing I've noticed though is when I execute a xen-create-image or a xen-delete-image command my dom0 keymap changes (not sure to what) and I have to issue a "dpkg-reconfigure console-setup". I live in the UK so I set my maps as such "en-gb". Whilst I've read various articles that describe setting the keymap for domU's I've seen nothing that describes what's happening to me.

Can anyone help?
Responses (3)
  • Accepted Answer

    Monday, August 05 2013, 08:54 PM - #permalink
    0
    So I can absolutely repeat this and it seems related to the 'Hook' process that xen-create-image calls. I believe my Dom0 layout is changing from en_GB to en_US although none of the files in /etc/default e.g. locales, keyboard, console-setup are being altered. I can easily correct the problem by running dpkg-reconfigure console-setup, alter none of the on-screen options and once completed my keyboard layout is back to norm.

    I've reviewed the hook scripts and whilst there is a locale section it seems correct although I'm not exactly qualified here so if anyone else has a view, this one is bugging me.

    K
    The reply is currently minimized Show
  • Accepted Answer

    Lars Kurth
    Lars Kurth
    Offline
    Tuesday, August 06 2013, 02:18 PM - #permalink
    0
    This sounds like a xen-tools bug. You can raise bugs on xen-tools via http://xen-tools.org/software/xen-tools/bugs.html and ask questions via http://xen-tools.org/mailman/listinfo/xen-tools-discuss
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 06 2013, 07:38 PM - #permalink
    0
    The reply is currently minimized Show
Your Reply