Error creating more than 16 DomU

posted in New Users
Saturday, December 21 2013, 06:05 PM
Pablo
Pablo
Offline
0
Hi.

I am using Ubuntu 12.10 with Xen-hypervisor 4.1 amd64 and toolstack xl.

I have a problem while trying to create more than 16 DomsU. I have already taken a look at the max_loop devices.

When I try to create the 17th guest it says.... "Failed to run bootloader :-3"

I can shutdown the 16vm and create another...but I can't never create more than 17.

Do you know why might this be happening? I have search and found nothing...

Thanks for your help

Please notice that I am using PV guests, and all of the disks are running on the same virtual group. I don't know whether that makes a difference.

Accepted Answer

Saturday, December 21 2013, 07:23 PM - #permalink
0
Does this thread seem to describe your problem?

http://www.gossamer-threads.com/lists/xen/users/247017?do=post_view_threaded#247017

The solution proposed in this thread (by Ian Campbell, one of the key Xen developers), is to either (1) upgrade to 4.2 or (2) use xend for 4.1 which does not have the bug.

Russ
The reply is currently minimized Show
Responses (4)
  • Accepted Answer

    Pablo
    Pablo
    Offline
    Saturday, December 21 2013, 07:34 PM - #permalink
    0
    Hi. Well..that wasn't pretty much my issue. However, I have tried what is written in the thread and it also happens to me.....so I'll give it a try to xend.

    BTW...this was my original problem.... (and for sure it is not a problem on bgpC17)

    Thanks. I'll tell you what happens...

    root@L3Lab:/etc/xen/clients# xl list
    Name                                        ID   Mem VCPUs      State   Time(s)
    Domain-0                                     0  2048    16     r-----     316.9
    bgpC1                                        3   200     1     -b----     545.9
    bgpC2                                        4   200     1     -b----     546.4
    bgpC3                                        5   200     1     -b----     545.5
    bgpC4                                        6   200     1     -b----     547.7
    bgpC5                                        7   200     1     -b----     547.7
    bgpC6                                        8   200     1     -b----     545.8
    bgpC7                                        9   200     1     -b----     547.7
    bgpC8                                       10   200     1     r-----     543.0
    bgpC9                                       11   200     1     -b----     544.7
    bgpC10                                      12   200     1     -b----     544.8
    bgpC11                                      13   200     1     -b----     546.4
    bgpC12                                      14   200     1     -b----     546.3
    bgpC13                                      15   200     1     -b----     545.7
    bgpC14                                      25   200     1     -b----     134.6
    bgpC15                                      26   200     1     -b----     134.4
    root@L3Lab:/etc/xen/clients# xl create bgpC16.cfg
    Parsing config file bgpC16.cfg
    Daemon running with PID 11239
    root@L3Lab:/etc/xen/clients# xl list
    Name                                        ID   Mem VCPUs      State   Time(s)
    Domain-0                                     0  2048    16     r-----     322.6
    bgpC1                                        3   200     1     -b----     548.9
    bgpC2                                        4   200     1     -b----     546.4
    bgpC3                                        5   200     1     -b----     545.5
    bgpC4                                        6   200     1     -b----     547.7
    bgpC5                                        7   200     1     -b----     547.7
    bgpC6                                        8   200     1     -b----     545.8
    bgpC7                                        9   200     1     -b----     547.7
    bgpC8                                       10   200     1     -b----     545.7
    bgpC9                                       11   200     1     -b----     547.7
    bgpC10                                      12   200     1     r-----     546.3
    bgpC11                                      13   200     1     -b----     546.5
    bgpC12                                      14   200     1     -b----     546.3
    bgpC13                                      15   200     1     -b----     545.7
    bgpC14                                      25   200     1     -b----     134.6
    bgpC15                                      26   200     1     -b----     134.4
    bgpC16                                      29   200     1     r-----       4.1
    root@L3Lab:/etc/xen/clients# xl create bgpC17.cfg
    Parsing config file bgpC17.cfg
    failed to run bootloader: -3
    
    The reply is currently minimized Show
  • Accepted Answer

    Pablo
    Pablo
    Offline
    Monday, December 23 2013, 04:17 PM - #permalink
    0
    Hi. I have tried using Xend but didn't work neither.

    Perhaps I should try to update xen....
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 23 2013, 04:45 PM - #permalink
    0
    I suggest you ask in the xen-users mailing list. Someone there may have some insight for you.
    The reply is currently minimized Show
  • Accepted Answer

    Pablo
    Pablo
    Offline
    Thursday, December 26 2013, 02:08 PM - #permalink
    0
    To be honest, I don't know what was happening in there. Probably a bug.
    I was running Xen 4.1 in Ubuntu 12.10

    Running Xen 4.2 in Ubuntu 13.04 solves everything. Now is working.

    Thanks :)
    The reply is currently minimized Show
Your Reply