Issue

domu ssh X11 fowarding how to

posted in New Users
Friday, September 20 2013, 02:54 PM
Sadar
Sadar
Offline
0
Hello,

My dom0 : debian wheezy boot in console mode (no X desktop installed). Putty ssh with X11-forwarding work fine. ex : virt-manager (with Windows 7 & X-win)

My Domu : debian wheezy (deboostrap install)

#
# Configuration file for the Xen instance debian-stable, created
# by xen-tools 4.3.1 on Tue Sep 17 21:46:36 2013.
#

#
#  Kernel + memory size
#


bootloader = '/usr/lib/xen-4.1/bin/pygrub'

vcpus       = '1'
memory      = '128'

#
#  Disk device(s).
#
root        = '/dev/xvda2 ro'
disk        = [
                  'file:/mnt/vol2To/08500.vm/xen/domains/wheezy/disk.img,xvda2,w',
                  'file:/mnt/vol2To/08500.vm/xen/domains/wheezy/swap.img,xvda1,w',
              ]


#
#  Physical volumes
#


#
#  Hostname
#
name        = 'wheezy'

#
#  Networking
#
dhcp        = 'dhcp'
vif         = [ '' ]

#
#  Behaviour
#
on_poweroff = 'destroy'
on_reboot   = 'restart'
on_crash    = 'restart'

vnc=0
sdl=1



ssh connxion with X11 forwarding not ok : RuntimeError: Unable to initialize GTK: could not open display

my /etc/ssh/sshd

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes


IPV6 is disable on VM client
Responses (1)
  • Accepted Answer

    Sadar
    Sadar
    Offline
    Friday, September 20 2013, 03:47 PM - #permalink
    0
    Resolved Title

    in /etc/ssh/sshd_config

    # Workaround to have X forwarding work when ipv6 is disabled
    AddressFamily inet
    The reply is currently minimized Show
Your Reply